<!doctype html><html lang="en-US"><head><meta charset="UTF-8" /><meta name="viewport" content="width=device-width, user-scalable=no, initial-scale=1.0, minimum-scale=1.0, maximum-scale=1.0"><meta http-equiv="X-UA-Compatible" content="IE=edge,chrome=1" /><link rel="profile" href="//gmpg.org/xfn/11" /><link rel="pingback" href="https://www.autoserviceworld.com/xmlrpc.php" /> <!--[if IE 7]><link rel="stylesheet" href="/wp-content/themes/strappress/css/font-awesome-ie7.min.css"> <![endif]--><meta name='robots' content='index, follow, max-image-preview:large, max-snippet:-1, max-video-preview:-1' /> <!-- This site is optimized with the Yoast SEO plugin v18.3 - https://yoast.com/wordpress/plugins/seo/ --><title>NTN announces new BCA parts additions - Auto Service World</title><link rel="preload" as="font" href="https://fonts.googleapis.com/css?family=Noto+Sans" crossorigin/><link rel="preload" as="font" href="https://fonts.googleapis.com/css?family=Noto+Serif" crossorigin/><link rel="stylesheet" id="siteground-optimizer-combined-css-676fd2b9281db21c17db4aa94416a6e3" href="https://www.autoserviceworld.com/wp-content/uploads/siteground-optimizer-assets/siteground-optimizer-combined-css-676fd2b9281db21c17db4aa94416a6e3.css" media="all" /><link rel="preload" href="https://www.autoserviceworld.com/wp-content/uploads/siteground-optimizer-assets/siteground-optimizer-combined-css-676fd2b9281db21c17db4aa94416a6e3.css" as="style"><meta name="description" content="NTN has added 16 new product SKUs to the BCA aftermarket product line. This release includes wheel hub assemblies and repair kits for a number of import" /><link rel="canonical" href="https://www.autoserviceworld.com/ntn-announces-new-bca-parts-additions/" /><meta property="og:locale" content="en_US" /><meta property="og:type" content="article" /><meta property="og:title" content="NTN announces new BCA parts additions - Auto Service World" /><meta property="og:description" content="NTN has added 16 new product SKUs to the BCA aftermarket product line. This release includes wheel hub assemblies and repair kits for a number of import" /><meta property="og:url" content="https://www.autoserviceworld.com/ntn-announces-new-bca-parts-additions/" /><meta property="og:site_name" content="Auto Service World" /><meta property="article:published_time" content="2022-04-04T10:10:31+00:00" /><meta property="article:modified_time" content="2022-03-30T20:13:59+00:00" /><meta property="og:image" content="https://www.autoserviceworld.com/wp-content/uploads/2022/03/NTN-Wheel-hub-repair-kit.jpg" /><meta property="og:image:width" content="500" /><meta property="og:image:height" content="317" /><meta property="og:image:type" content="image/jpeg" /><meta name="twitter:label1" content="Written by" /><meta name="twitter:data1" content="Adam Malik" /><meta name="twitter:label2" content="Est. reading time" /><meta name="twitter:data2" content="1 minute" /> <script type="application/ld+json" class="yoast-schema-graph">{"@context":"https://schema.org","@graph":[{"@type":"WebSite","@id":"https://www.autoserviceworld.com/#website","url":"https://www.autoserviceworld.com/","name":"Auto Service World","description":"Reaching Canada&#039;s Automotive Aftermarket Industry","potentialAction":[{"@type":"SearchAction","target":{"@type":"EntryPoint","urlTemplate":"https://www.autoserviceworld.com/?s={search_term_string}"},"query-input":"required name=search_term_string"}],"inLanguage":"en-US"},{"@type":"ImageObject","@id":"https://www.autoserviceworld.com/ntn-announces-new-bca-parts-additions/#primaryimage","inLanguage":"en-US","url":"https://www.autoserviceworld.com/wp-content/uploads/2022/03/NTN-Wheel-hub-repair-kit.jpg","contentUrl":"https://www.autoserviceworld.com/wp-content/uploads/2022/03/NTN-Wheel-hub-repair-kit.jpg","width":500,"height":317},{"@type":"WebPage","@id":"https://www.autoserviceworld.com/ntn-announces-new-bca-parts-additions/#webpage","url":"https://www.autoserviceworld.com/ntn-announces-new-bca-parts-additions/","name":"NTN announces new BCA parts additions - Auto Service World","isPartOf":{"@id":"https://www.autoserviceworld.com/#website"},"primaryImageOfPage":{"@id":"https://www.autoserviceworld.com/ntn-announces-new-bca-parts-additions/#primaryimage"},"datePublished":"2022-04-04T10:10:31+00:00","dateModified":"2022-03-30T20:13:59+00:00","author":{"@id":"https://www.autoserviceworld.com/#/schema/person/13d3f9d78527dc0b4c4b445bc2cf0850"},"description":"NTN has added 16 new product SKUs to the BCA aftermarket product line. This release includes wheel hub assemblies and repair kits for a number of import","breadcrumb":{"@id":"https://www.autoserviceworld.com/ntn-announces-new-bca-parts-additions/#breadcrumb"},"inLanguage":"en-US","potentialAction":[{"@type":"ReadAction","target":["https://www.autoserviceworld.com/ntn-announces-new-bca-parts-additions/"]}]},{"@type":"BreadcrumbList","@id":"https://www.autoserviceworld.com/ntn-announces-new-bca-parts-additions/#breadcrumb","itemListElement":[{"@type":"ListItem","position":1,"name":"Home","item":"https://www.autoserviceworld.com/"},{"@type":"ListItem","position":2,"name":"NTN announces new BCA parts additions"}]},{"@type":"Person","@id":"https://www.autoserviceworld.com/#/schema/person/13d3f9d78527dc0b4c4b445bc2cf0850","name":"Adam Malik","image":{"@type":"ImageObject","@id":"https://www.autoserviceworld.com/#personlogo","inLanguage":"en-US","url":"https://secure.gravatar.com/avatar/41d9ef84da4143cb3d2334b044bcbb3a?s=96&d=mm&r=g","contentUrl":"https://secure.gravatar.com/avatar/41d9ef84da4143cb3d2334b044bcbb3a?s=96&d=mm&r=g","caption":"Adam Malik"}}]}</script> <!-- / Yoast SEO plugin. --><link rel='dns-prefetch' href='//s.w.org' /><link rel="alternate" type="application/rss+xml" title="Auto Service World &raquo; Feed" href="https://www.autoserviceworld.com/feed/" /><link rel="alternate" type="application/rss+xml" title="Auto Service World &raquo; Comments Feed" href="https://www.autoserviceworld.com/comments/feed/" /><link rel="alternate" type="application/rss+xml" title="Auto Service World &raquo; NTN announces new BCA parts additions Comments Feed" href="https://www.autoserviceworld.com/ntn-announces-new-bca-parts-additions/feed/" /> <style type="text/css"> img.wp-smiley,
img.emoji {
 display: inline !important;
 border: none !important;
 box-shadow: none !important;
 height: 1em !important;
 width: 1em !important;
 margin: 0 0.07em !important;
 vertical-align: -0.1em !important;
 background: none !important;
 padding: 0 !important;
} </style> <style id='global-styles-inline-css' type='text/css'>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</style><link rel='stylesheet' id='woocommerce-smallscreen-css'  href='https://www.autoserviceworld.com/wp-content/plugins/woocommerce/assets/css/woocommerce-smallscreen.min.css?ver=6.3.1' type='text/css' media='only screen and (max-width: 768px)' /> <style id='woocommerce-inline-inline-css' type='text/css'> .woocommerce form .form-row .required { visibility: visible; } </style> <script type='text/javascript' src='https://www.autoserviceworld.com/wp-content/plugins/enable-jquery-migrate-helper/js/jquery/jquery-1.12.4-wp.js?ver=1.12.4-wp' id='jquery-core-js'></script> <script type='text/javascript' id='gainwp-tracking-analytics-events-js-extra'> /* <![CDATA[ */
var gainwpUAEventsData = {"options":{"event_tracking":"1","event_downloads":"zip|mp3*|mpe*g|pdf|docx*|pptx*|xlsx*|rar*","event_bouncerate":0,"aff_tracking":1,"event_affiliates":"\/out\/","hash_tracking":"1","root_domain":"autoserviceworld.com","event_timeout":100,"event_precision":1,"event_formsubmit":1,"ga_pagescrolldepth_tracking":1,"ga_with_gtag":0}};
/* ]]> */ </script> <script defer type='application/json' id='wpp-json'> {"sampling_active":0,"sampling_rate":100,"ajax_url":"https:\/\/www.autoserviceworld.com\/wp-json\/wordpress-popular-posts\/v1\/popular-posts","api_url":"https:\/\/www.autoserviceworld.com\/wp-json\/wordpress-popular-posts","ID":1003830707,"token":"17814d2289","lang":0,"debug":0} </script><link rel="https://api.w.org/" href="https://www.autoserviceworld.com/wp-json/" /><link rel="alternate" type="application/json" href="https://www.autoserviceworld.com/wp-json/wp/v2/posts/1003830707" /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.autoserviceworld.com/xmlrpc.php?rsd" /><link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://www.autoserviceworld.com/wp-includes/wlwmanifest.xml" /><link rel='shortlink' href='https://www.autoserviceworld.com/?p=1003830707' /><link rel="alternate" type="application/json+oembed" href="https://www.autoserviceworld.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.autoserviceworld.com%2Fntn-announces-new-bca-parts-additions%2F" /><link rel="alternate" type="text/xml+oembed" href="https://www.autoserviceworld.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.autoserviceworld.com%2Fntn-announces-new-bca-parts-additions%2F&#038;format=xml" /> <style id="wpp-loading-animation-styles">@-webkit-keyframes bgslide{from{background-position-x:0}to{background-position-x:-200%}}@keyframes bgslide{from{background-position-x:0}to{background-position-x:-200%}}.wpp-widget-placeholder,.wpp-widget-block-placeholder{margin:0 auto;width:60px;height:3px;background:#dd3737;background:linear-gradient(90deg,#dd3737 0%,#571313 10%,#dd3737 100%);background-size:200% auto;border-radius:3px;-webkit-animation:bgslide 1s infinite linear;animation:bgslide 1s infinite linear}</style> <script type="text/javascript"> // <![CDATA[
 jQuery(document).ready(function($){
 $("a[rel='magnific']").magnificPopup({
 type:'image'
 });
 }); 
 // ]]> </script> <!-- Custom CSS --> <style type="text/css"> .gpoll_wrapper ul.gfield_radio li { padding:5px !important; }header { background: ;}.navbar-brand { font-weight: normal; }.navbar-nav > li > a, .dropdown-menu > li > a { font-weight: normal; } </style> <noscript><style>.woocommerce-product-gallery{ opacity: 1 !important; }</style></noscript><link rel="icon" href="https://www.autoserviceworld.com/wp-content/uploads/2019/08/cropped-ASW-FAVICON-1-32x32.png" sizes="32x32" /><link rel="icon" href="https://www.autoserviceworld.com/wp-content/uploads/2019/08/cropped-ASW-FAVICON-1-192x192.png" sizes="192x192" /><link rel="apple-touch-icon" href="https://www.autoserviceworld.com/wp-content/uploads/2019/08/cropped-ASW-FAVICON-1-180x180.png" /><meta name="msapplication-TileImage" content="https://www.autoserviceworld.com/wp-content/uploads/2019/08/cropped-ASW-FAVICON-1-270x270.png" /> <!-- BEGIN GAINWP v5.4.6 Universal Analytics - https://intelligencewp.com/google-analytics-in-wordpress/ --> <script> (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
 (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
 m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
})(window,document,'script','https://www.google-analytics.com/analytics.js','ga');
 ga('create', 'UA-11137870-21', 'auto');
 ga('require', 'displayfeatures');
 ga('require', 'linkid');
 ga('set', 'forceSSL', true);
 ga('send', 'pageview'); </script> <!-- END GAINWP Universal Analytics --> <!-- Google Tag Manager --> <script>(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
 new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
 j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
 '//www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);
 })(window,document,'script','dataLayer','GTM-MPCX4X');</script> <!-- End Google Tag Manager --> <!-- HTML5 shim and Respond.js IE8 support of HTML5 elements and media queries --> <!--[if lt IE 9]> <script src="https://oss.maxcdn.com/libs/html5shiv/3.7.0/html5shiv.js"></script> <script src="https://oss.maxcdn.com/libs/respond.js/1.3.0/respond.min.js"></script> <![endif]--> <!-- dfp start --> <script async='async' src='//securepubads.g.doubleclick.net/tag/js/gpt.js'></script> <!-- dfp end --> <!-- needed for sharign buttons --> <!-- twitter --> <!-- facebook --><div id="fb-root"></div> <!-- google plus --> <!-- sharing buttons end --></head><body class="post-template-default single single-post postid-1003830707 single-format-standard wp-custom-logo theme-strappress woocommerce-no-js"> <!-- Google Tag Manager --> <noscript><iframe src="//www.googletagmanager.com/ns.html?id=GTM-MPCX4X"
height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript> <!-- End Google Tag Manager --><header class="masthead" id="newcom-header-masthead"><div id="mega-menu" style="display:none;"><div class="container"><div class="row"><div class="col-xs-6"> <img src="/wp-content/themes/pubx-asw/images/SWlogo-2019_hor_white-(002).png" alt="Auto Service World" /> &nbsp;&nbsp; <a class="small" href="/subscribe/"><strong>Subscribe</strong></a></div><div class="col-xs-6"> <a href="#" id="closemenu" class="pull-right">&times;</a></div></div> <br/><div class="row"><div class="col-md-3 col-sm-4"><div class="main-menu"><div class="menu-main-navigation-container"><ul id="menu-main-navigation" class="menu"><li id="menu-item-1003260455" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-1003260455"><a href="https://www.autoserviceworld.com/news/">News</a></li><li id="menu-item-1003821188" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-1003821188"><a href="https://www.autoserviceworld.com/covid-19/">Covid-19 Hub</a></li><li id="menu-item-1003260457" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-1003260457"><a href="/features/">Features</a></li><li id="menu-item-1003260459" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-1003260459"><a href="/news_products">Products</a></li><li id="menu-item-1003803068" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-1003803068"><a href="/podcasts">Podcasts</a></li><li id="menu-item-1003806982" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-1003806982"><a href="/gallery">Gallery</a></li><li id="menu-item-1003766493" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-1003766493"><a href="/events">Upcoming Events</a></li></ul></div></div><div class="menu-information-container"><ul id="menu-information" class="menu"><li id="menu-item-1003766529" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-1003766529"><a href="/resources">Resources</a></li><li id="menu-item-1003766528" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-1003766528"><a href="https://www.autoserviceworld.com/awards/">Awards</a></li><li id="menu-item-1003766297" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-1003766297"><a href="https://www.autoserviceworld.com/digital-archives/">Digital Archives</a></li><li id="menu-item-1003766295" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-1003766295"><a href="https://www.autoserviceworld.com/advertise/">Advertise</a></li><li id="menu-item-1003766296" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-1003766296"><a href="https://www.autoserviceworld.com/contacts/">Contacts</a></li></ul></div> <br/><div class="hidden-xs hidden-sm"><h6 style="padding-left:6px;font-weight:normal;">Follow Us</h6><div class="btn-group"> <button type="button" class="btn btn-primary dropdown-toggle" data-toggle="dropdown"> <i class="icon-facebook"></i> Facebook <span class="caret"></span> </button><ul class="dropdown-menu"><li><a href="//www.facebook.com/pages/AutoServiceWorldcom/244916465611841" target="_blank">AutoServiceWorld.com</a></li><li><a href="//www.facebook.com/myCARSmagazine" target="_blank">CARS Magazine</a></li></ul></div></div></div><div class="col-md-9 col-sm-8"><h4>Topics</h4><div class="row"><div class="col-sm-4"><div class="menu-topics-1-container"><ul id="menu-topics-1" class="menu"><li id="menu-item-1003766298" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-1003766298"><a href="https://www.autoserviceworld.com/category/association-news/">Association News</a></li><li id="menu-item-1003766299" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-1003766299"><a href="https://www.autoserviceworld.com/category/auto-repair-service/">Auto Repair &#038; Service</a></li><li id="menu-item-1003766300" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-1003766300"><a href="https://www.autoserviceworld.com/category/business-management/">Business Management</a></li><li id="menu-item-1003766301" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-1003766301"><a href="https://www.autoserviceworld.com/category/charity-fundraising/">Charity &#038; Fundraising</a></li><li id="menu-item-1003766413" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-1003766413"><a href="https://www.autoserviceworld.com/category/customer-relations/">Customer Relations</a></li></ul></div></div><div class="col-sm-4"><div class="menu-topics-2-container"><ul id="menu-topics-2" class="menu"><li id="menu-item-1003766411" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-1003766411"><a href="https://www.autoserviceworld.com/category/event-news/">Event News</a></li><li id="menu-item-1003766412" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-1003766412"><a href="https://www.autoserviceworld.com/category/jobbers-wds/">Jobbers &#038; WDs</a></li><li id="menu-item-1003766305" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-1003766305"><a href="https://www.autoserviceworld.com/category/legislation-regulations/">Legislation Regulations</a></li><li id="menu-item-1003766414" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-1003766414"><a href="https://www.autoserviceworld.com/category/market-research-statistics/">Market Research &#038; Statistics</a></li><li id="menu-item-1003766415" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-1003766415"><a href="https://www.autoserviceworld.com/category/milestones-awards/">Milestones &#038; Awards</a></li></ul></div></div><div class="col-sm-4"><div class="menu-topics-3-container"><ul id="menu-topics-3" class="menu"><li id="menu-item-1003766420" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-1003766420"><a href="https://www.autoserviceworld.com/category/people-profiles/">People &#038; Profiles</a></li><li id="menu-item-1003766421" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-1003766421"><a href="https://www.autoserviceworld.com/category/supplier-news-announcements/">Supplier News &#038; Announcements</a></li><li id="menu-item-1003766423" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-1003766423"><a href="https://www.autoserviceworld.com/category/vehicle-technology/">Vehicle Technology</a></li></ul></div></div></div> <br/><div class="hidden-sm hidden-xs"><h4>Digital Editions</h4><div class="textwidget"><div class="row"><div class="col-md-4"><p><a href="/digital-edition/cars/"><img src="https://www.autoserviceworld.com/wp-content/uploads/2022/03/CARS-Feb2022_cover.jpg" /></a></p></div><div class="col-md-4"><p><a href="/digital-edition/jobber-news"><img src="https://www.autoserviceworld.com/wp-content/uploads/2022/02/JN-Jan2022_cover.jpg" alt="Current Issue - Jobber News" /></a></p></div></div></div></div></div></div></div></div><div class="masthead-inner"><nav role="navigation" id="navbar-wrapper"><div class="navbar navbar-default"><div class="container"><div class="col-md-12" style="padding-top:20px;"> <a href="#" id="btn-menu" class="menu-icon" title="Click to show site navigation" style="margin-right:5px;"></a> <a href="https://www.autoserviceworld.com/" title="Auto Service World" rel="home"
 class="logo" style="margin:0px;"> <img src="/wp-content/themes/pubx-asw/images/asw-new.png" width="355px;" style="padding-top:20px;margin:0px;"
 alt="Auto Service World" class="img-resposnive" /> </a><div class="-center"><div id='div-gpt-ad-3406187699805779-1'></div></div></div></div><div class="container"><ul class="nav navbar-nav visible-lg visible-md brands-nav"><li><a href="/jobbernews"><img
 src="/wp-content/themes/pubx-asw/images/jobber-menu-logo.png"
 alt="Jobber News" /></a></li><li><a href="/carsmagazine"><img
 src="/wp-content/themes/pubx-asw/images/cars-menu-logo.png"
 alt="CARS Magazine" /></a></li><li><a href="/shop" class="header-button">SHOP</a></li><li><a href="/category/commentary/" class="header-button">COMMENTARY</a></li><li><a href="/podcasts" class="header-button">PODCASTS</a></li><li><a href="/digital-edition" class="header-button">DIGITAL EDITION</a></li></ul><ul class="nav navbar-nav navbar-right"><li style="padding-top:20px"><form role="search" method="get" class="navbar-form" action="https://www.autoserviceworld.com/" class="collapse" id="searchform"> <input name="s" id="s" type="text" class="form-control" placeholder="Search"></form></li></ul></div><hr class="hr-head" /></div></nav></header><!-- end of header --><div id="screen-area"><div class="container"><div id="wrapper"><div class="visible-print"> <img src="/wp-content/uploads/sites/10/2015/09/asw-logo-concept.png" alt="Auto Service World" /></div><div class="row"><div class="col-md-9 ncm-col-md-9"><div class="post-edit"></div> <a href="/news" class="label label-primary">News</a> &nbsp; <small class="text-muted"> April 4, 2022 &nbsp; <strong> by
 Adam Malik </strong> </small><h1 class="media-heading"> NTN announces new BCA parts additions</h1><p class="lead"></p><hr /><div class="row"><div class="col-md-3 hidden-xs hidden-sm"> <img src="/wp-content/themes/pubx-asw/images/single_Auto_Service_World.png" alt="Auto_Service_World" /><hr /><img src="/wp-content/themes/pubx-asw/images/single_CARS_Magazine.png" alt="CARS_Magazine" /><hr /><img src="/wp-content/themes/pubx-asw/images/single_Jobber_News.png" alt="Jobber_News" /><hr /> <br/><br/><div class="panel panel-default"><div class="panel-body"> <!-- related categories --><div class="heading-primary">Topics</div><ul class="nav nav-list"><li><a href="https://www.autoserviceworld.com/category/auto-repair-service/">Auto Repair &amp; Service</a></li><li><a href="https://www.autoserviceworld.com/category/jobbers-wds/">Jobbers &amp; WDs</a></li><li><a href="https://www.autoserviceworld.com/category/supplier-news-announcements/">Supplier News &amp; Announcements</a></li></ul> <br/> <a href="/news" class="btn btn-default btn-block">More News</a></div></div></div> <!-- /col-md-3--><div class="col-md-9"><div class="the-content"><p>NTN has added 16 new product SKUs to the BCA aftermarket product line. This release includes wheel hub assemblies and repair kits for a number of import and domestic applications, covering almost seven million vehicles in operation.</p><p>The new SKUs supplement BCA’s coverage for popular Asian brands, including Hyundai, Kia, Nissan, Infinity, Toyota, Lexus and Mazda. There is also added coverage for Mercedes-Benz GLS-Class SUVs, which recently began production with the 2020 model year.</p><p>Furthermore, the company added coverage for multiple Ford brands, including the first-generation Ford Fusion platform, the third generation mid-cycle refresh of the Expedition/Navigator, and the first generation of Ford’s high-performance F-150 SVT Raptor.</p><p>“This final release of our 2021 fiscal year serves to keep the BCA product line aligned with the demand we see in the aftermarket,” said Rina Dafnis, assistant product manager – automotive aftermarket. “We base our product line additions on multiple data points, and a majority of these new applications are just now coming into the aftermarket sweet spot where we begin to see the vehicle age and mileage that necessitates the replacement of the original equipment wheel hubs.”</p></div><div class="clearfix"></div><div class="hidden-print"><hr /> <a class="btn btn-default btn-xs pull-right" href="javascript:window.print()"><i class="icon-print"></i> Print this page</a><ul class="list-inline"><li><a href="https://twitter.com/share" class="twitter-share-button" data-via="JobberNews" data-count="none">Tweet</a></li><li><div class="fb-share-button" data-layout="button"></div></li><li> <script src="//platform.linkedin.com/in.js" type="text/javascript">lang: en_US</script><script type="IN/Share" data-url="https://www.autoserviceworld.com/ntn-announces-new-bca-parts-additions/"></script></li><li><div class="g-plus" data-action="share" data-annotation="none"></div></li></ul> <br/><br/><div class="heading-primary">Related</div><div class='yarpp yarpp-related yarpp-related-website yarpp-template-yarpp-template-thumbnail'><ul class="headlines"><li class="headline-item"><h5> <img src="/wp-content/themes/pubx-asw/images/Jobber_News.png" alt="Jobber_News" class="pull-right" /> <a href="https://www.autoserviceworld.com/jobbernews/ntn-bca-bearings-launch-loose-bearing-program/" class="headline">NTN and BCA Bearings Launch Loose Bearing Program</a></h5></li><li class="headline-item"><h5> <img src="/wp-content/themes/pubx-asw/images/Auto_Service_World.png" alt="Auto_Service_World" class="pull-right" /> <a href="https://www.autoserviceworld.com/category-focus-brakes-5/" class="headline">Category Focus: BRAKES</a></h5></li><li class="headline-item"><h5> <img src="/wp-content/themes/pubx-asw/images/Auto_Service_World.png" alt="Auto_Service_World" class="pull-right" /> <a href="https://www.autoserviceworld.com/bca-adds-to-product-line/" class="headline">BCA adds to product line</a></h5></li><li class="headline-item"><h5> <img src="/wp-content/themes/pubx-asw/images/Auto_Service_World.png" alt="Auto_Service_World" class="pull-right" /> <a href="https://www.autoserviceworld.com/category-focus-brakes-6/" class="headline">Category Focus: <span style=color:#ff0000> BRAKES</span></a></h5></li></ul></div> <br/><br/> <a name="comments" id="comments"></a><div id="respond" class="comment-respond"><h3 id="reply-title" class="comment-reply-title">Have your say: <small><a rel="nofollow" id="cancel-comment-reply-link" href="/ntn-announces-new-bca-parts-additions/#respond" style="display:none;">Cancel reply</a></small></h3><form action="https://www.autoserviceworld.com/wp-comments-post.php" method="post" id="commentform" class="comment-form"><p class="comment-notes"><span id="email-notes">Your email address will not be published.</span> <span class="required-field-message" aria-hidden="true">Required fields are marked <span class="required" aria-hidden="true">*</span></span></p><p class="comment-form-comment"><textarea id="comment" name="comment" cols="45" rows="8" aria-required="true"></textarea></p><p class="comment-form-author"><label for="author">Name</label> <span class="required">*</span><input id="author" name="author" type="text" value="" size="30" /></p><p class="comment-form-email"><label for="email">E-mail</label> <span class="required">*</span><input id="email" name="email" type="text" value="" size="30" /></p><p class="comment-form-url"><label for="url">Website</label><input id="url" name="url" type="text" value="" size="30" /></p><p class="comment-form-cookies-consent"><input id="wp-comment-cookies-consent" name="wp-comment-cookies-consent" type="checkbox" value="yes" /> <label for="wp-comment-cookies-consent">Save my name, email, and website in this browser for the next time I comment.</label></p><p class="form-submit"><input name="submit" type="submit" id="btn-post-comment" class="submit" value="Post Comment" /> <input type='hidden' name='comment_post_ID' value='1003830707' id='comment_post_ID' /> <input type='hidden' name='comment_parent' id='comment_parent' value='0' /></p><p style="display: none;"><input type="hidden" id="akismet_comment_nonce" name="akismet_comment_nonce" value="547b70c74a" /></p><p style="display: none !important;"><label>&#916;<textarea name="ak_hp_textarea" cols="45" rows="8" maxlength="100"></textarea></label><input type="hidden" id="ak_js_1" name="ak_js" value="97"/></p></form></div><!-- #respond --></div></div> <!-- /col-md-9-inner --></div> <!-- /row --></div> <!-- /col-md-9 --><div class="col-md-3 ncm-col-md-3"><aside id="widgets"><div id="text-4" class="widget-wrapper widget_text"><div class="textwidget"><div class="center-block text-center"><div id="div-gpt-ad-3406187699805779-2"></div> <br/><br/><div id="div-gpt-ad-3406187699805779-3"></div> <br/><br/><div id="div-gpt-ad-3406187699805779-5"></div> <br/><div id="div-gpt-ad-3406187699805779-4"></div></div></div></div></aside><!-- end of widgets --></div></div><!-- ./row--><div class="row"><div class="col-md-12"><div id='div-gpt-ad-3406187699805779-6' style="display:inline-block;margin:0px 0px 25px 0px;text-align:center;"></div></div></div><ul class="pager"><li class="pull-left"><i class="icon-arrow-left"></i> <a href="https://www.autoserviceworld.com/why-you-should-expect-more-ma-activity/" rel="prev">Why you should expect more M&#038;A activity</a></li><li class="pull-right"><a href="https://www.autoserviceworld.com/milwaukee-adds-new-colour-match-light/" rel="next">Milwaukee adds new colour match light</a> <i class="icon-arrow-right"></i></li></ul><!-- end of .navigation --></div> <!-- /container --></div><!-- wrapper --></div><!-- end of wrapper--></div><!-- end of container --></div> <!-- end of screen-area --><footer id="footer" class="clearfix "><div class="container"><div id="footer-wrapper"><div class="row"><div class="col-md-2"><div id="footer1"><div class="heading-primary">Services</div><div class="menu-services-container"><ul id="menu-services" class="menu"><li id="menu-item-1003488286" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-1003488286"><a href="https://www.autoserviceworld.com/subscribe/">Subscriber Services</a></li><li id="menu-item-1003260493" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-1003260493"><a href="https://www.autoserviceworld.com/digital-edition/">Digital Edition</a></li><li id="menu-item-1003260494" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-1003260494"><a href="https://www.autoserviceworld.com/digital-archives/">Digital Archives</a></li><li id="menu-item-1003260469" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-1003260469"><a href="https://www.autoserviceworld.com/advertise/">Advertise</a></li><li id="menu-item-1003260468" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-1003260468"><a href="https://www.autoserviceworld.com/contacts/">Contacts</a></li><li id="menu-item-1003804544" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-1003804544"><a href="https://www.autoserviceworld.com/privacy-policy/">Privacy Policy</a></li></ul></div></div></div><div class="col-md-6"><div id="footer2"><div class="heading-primary">Digital Editions</div><div class="textwidget"><div class="row"><div class="col-md-6"><p><a href="/digital-edition/jobber-news"><img src="https://www.autoserviceworld.com/wp-content/uploads/2022/02/JN-Jan2022_cover.jpg" alt="Current Issue - Jobber News" /></a></p><p><a class="btn btn-primary btn-block ncm-btn-sm-xs" href="/digital-edition/jobber-news">View Digital Edition</a><br /> <a class="btn btn-sm btn-default btn-block ncm-btn-sm-xs" href="/jobbernews-archive">Browse Print Archives</a></p></div><div class="col-md-6"><p><a href="/digital-edition/cars/"><img src="https://www.autoserviceworld.com/wp-content/uploads/2022/03/CARS-Feb2022_cover.jpg" alt="Current Issue - CARS" /></a></p><p><a class="btn btn-primary btn-block ncm-btn-sm-xs" href="/digital-edition/cars/">View Digital Edition</a><br /> <a class="btn btn-sm btn-default btn-block ncm-btn-sm-xs" href="/cars_archive/">Browse Print Archives</a></p></div><p><!--<div class="col-md-6"> <a href="http://www.lautomobile.ca/digital-edition/"><img src="https://www.lautomobile.ca/wp-content/uploads/2019/07/LAUTO-DE-SUMMER-2019.jpg" alt="Current Issue - L'automobile" /></a> <a class="btn btn-primary btn-block ncm-btn-sm-xs" href="http://www.lautomobile.ca/digital-edition/">View Digital Edition</a> <a class="btn btn-sm btn-default btn-block ncm-btn-sm-xs" href="http://www.lautomobile.ca/digital-archive">Browse Print Archives</a></div> --></p></div></div></div></div><div class="col-md-4"><div id="footer3"><div class="heading-primary">Trending</div><div class="wpp-widget-placeholder" data-widget-id="wpp-2"></div></div></div></div><!-- end of row --><hr /><div class="row"><div class="col-md-7"> <img src="/wp-content/themes/pubx-asw/images/asw-stacked-70.png" alt="Auto Service World" style="margin-right:20px;" /> <img src="/wp-content/themes/pubx-asw/images/Jobber_News.png" alt="Jobber News" style="margin-right:20px;" /> <img src="/wp-content/themes/pubx-asw/images/CARS_Magazine.png" alt="CARS Magazine" style="margin-right:20px;" /></div><!-- end of col-lg-4 --><div class="col-md-2"> <a href="#scroll-top" title="scroll to top"><i class="icon-chevron-up"></i></a></div><div class="col-md-3"><div class="pull-right text-right"> <img src="/wp-content/uploads/2020/02/Turnkey_logo-1.png" alt="TRNKY" /><br/> <small>&copy; 2022 Turnkey Media Solutions Inc.</small><br/></div></div><!-- end of col-lg-4 --></div><!-- end of row --> <br/><br/></div><!-- end #footer-wrapper --></div> <!-- end container --></footer><!-- end #footer --> <!-- Google Code for Remarketing Tag --> <!--------------------------------------------------
Remarketing tags may not be associated with personally identifiable information or placed on pages related to sensitive categories. See more information and instructions on how to setup the tag on: http://google.com/ads/remarketingsetup
---------------------------------------------------> <script type="text/javascript"> /* <![CDATA[ */
var google_conversion_id = 1064152676;
var google_custom_params = window.google_tag_params;
var google_remarketing_only = true;
/* ]]> */ </script> <script type="text/javascript" src="//www.googleadservices.com/pagead/conversion.js"> </script> <noscript><div style="display:inline;"> <img height="1" width="1" style="border-style:none;" alt="" src="//googleads.g.doubleclick.net/pagead/viewthroughconversion/1064152676/?guid=ON&script=0"/></div> </noscript> <script type='text/javascript' id='wc-add-to-cart-js-extra'> /* <![CDATA[ */
var wc_add_to_cart_params = {"ajax_url":"\/wp-admin\/admin-ajax.php","wc_ajax_url":"\/?wc-ajax=%%endpoint%%","i18n_view_cart":"View cart","cart_url":"https:\/\/www.autoserviceworld.com\/cart\/","is_cart":"","cart_redirect_after_add":"no"};
/* ]]> */ </script> <script type='text/javascript' id='woocommerce-js-extra'> /* <![CDATA[ */
var woocommerce_params = {"ajax_url":"\/wp-admin\/admin-ajax.php","wc_ajax_url":"\/?wc-ajax=%%endpoint%%"};
/* ]]> */ </script> <script type='text/javascript' id='wc-cart-fragments-js-extra'> /* <![CDATA[ */
var wc_cart_fragments_params = {"ajax_url":"\/wp-admin\/admin-ajax.php","wc_ajax_url":"\/?wc-ajax=%%endpoint%%","cart_hash_key":"wc_cart_hash_49db3ce7801801e3565b572198fe6c0d","fragment_name":"wc_fragments_49db3ce7801801e3565b572198fe6c0d","request_timeout":"5000"};
/* ]]> */ </script> <script type='text/javascript' id='jquery-floatton-js-extra'> /* <![CDATA[ */
var floatton = {"ajaxurl":"https:\/\/www.autoserviceworld.com\/wp-admin\/admin-ajax.php"};
/* ]]> */ </script><div id='div-gpt-ad-3406187699805779-0-oop'></div> <!--
Event snippet for Sirius XM_Partners_Global Site Tag_Mar 2021 on : Please do not remove.
Place this snippet on pages with events you’re tracking. 
Creation date: 03/31/2021
--> <script> gtag('event', 'conversion', {
 'allow_custom_scripts': true,
 'send_to': 'DC-10768992/invmedia/siriu00+standard'
 }); </script> <noscript> <img src="https://ad.doubleclick.net/ddm/activity/src=10768992;type=invmedia;cat=siriu00;dc_lat=;dc_rdid=;tag_for_child_directed_treatment=;tfua=;npa=;gdpr=${GDPR};gdpr_consent=${GDPR_CONSENT_755};ord=1?" width="1" height="1" alt=""/> </noscript> <!-- End of event snippet: Please do not remove --> <!-- Conversion Pixel - Campbell's - CA - Universal - EN - CAPTURE --><img src="https://secure.adnxs.com/px?id=1464447&seg=26084091&redir=https%3A%2F%2Fpixel.mediaiqdigital.com%2Fpixel%3F%26pixel_id%3D1370728%26uid%3D%24%7BUID%7D&t=2" width="1" height="1" style="display:none;"><!-- End of Conversion Pixel --> <script defer src="https://www.autoserviceworld.com/wp-content/uploads/siteground-optimizer-assets/siteground-optimizer-combined-js-d1024c305ef18897e414c3ce5a41cba6.js"></script></body></html>